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This guide contains sections on: 
·  Creating basic pages 
·  Adding and altering images 
·  Various ways of manipulating text 
·  Creating and working with a site 
Please notify me with any errata/additions. 
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Creating a Basic Web Page 
   

 
 
Objectives of this section 
 
Generally: To create a basic web page by adding and formatting text. 
 
Specifically: On completion of this section, you will be able to:  

·  Create a web page  
·  Add and edit text  
·  Change font combinations, sizes and styles  
·  Align text  
·  Change the text colour  
·  Save and title a web page  

Web pages can be created to display almost any type of information. You might create a page to contain features of a 
product or company or to publish an online report. 
 
Text is still where most of the value lies in web pages. When you develop text for a web page you need to make it 
easy to read. Reading from a computer screen is relatively hard work, so text needs to be brief and to the point. It is 
best to present information in small "chunks". Relatively narrow columns with plenty of white space to help the user 
keep his or her place are ideal. 
 
Creating a New Web Page 
 
To create a new web page  

·  From the File menu, select New (SpeedKey: Ctrl + N)  

A new web page window is opened. 
 
Adding and Editing Text 
 
Entering text onto the page is like typing text in a word processor. 
 
To add text to a page  

·  Type the text directly into the document window  
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New web page window 

To edit text  

·  Click to position the insertion point within the document text and type in the new text  

OR  

·  Select the existing text and overtype replacing it with the new text  

To move and copy text 
 
Dreamweaver has the usual Cut, Copy and Paste tools.  

·  Select the text to copy or move  
·  From the Edit menu, select Copy (SpeedKey: Ctrl + C) or Cut (SpeedKey: Ctrl + X)  
·  Click in the document where you want the text to go then from the Edit menu, select Paste (SpeedKey: Ctrl 

+ V)  

Editing shortcuts 
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Formatting Text 
 
Basic formatting on a web page is achieved using HTML tags. Tags are used to describe the structure of text and its 
appearance. You do not need to know the tags themselves to apply formatting to text. This can be done using the 
Property Inspector and/or the Text menu. 
 
The structure of text means its organisation into headings, body text, lists and so on. There are a variety of tags 
available to do this. These tags are interpreted by the browser, which displays them with appropriate physical 
characteristics. For example, it displays an <H1> paragraph with a larger font size than ordinary body text <P> 
paragraphs. Heading tags should be used in sequence. For example, you should not jump from <H1> to <H6>. 
 
It is not as easy to determine the appearance of text on a web page as it is in a word processor. You have to consider 
that fonts or colours you choose may not be available on all systems. You cannot set specific font sizes in basic HTML, 
you need to think in terms of relative size. Because pages are displayed in a resizable window, possibly at a different 
screen resolution, you have to be aware that the page size may be different for different users. 
 
Applying Fonts and Font Combinations 
 
When you choose fonts to use on your pages, you need to consider the following:  

·  As with a printed document, mixing too many different font styles and over-using enhancements such as bold 
and italic does not produce a good effect.  

·  Sans serif fonts (fonts without curly edges, such as the heading above) are considered to be easier to read 
on-screen.  

·  If you use unusual fonts, it is unlikely that users will see the page as you do.  

Font combinations 
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When a user browses a website, the pages can only be displayed using fonts available on their own computer system. 
If fonts you specify are not available, another font will be substituted. 
 
In Dreamweaver, instead of applying a font to text, you apply a font combination. If the first choice font is not 
available, the second choice will be used; if the first and second fonts are not available, the third will be used; and so 
on. The font combination should specify broadly similar fonts, so that if one is missing, the effect on the page will not 
be so noticeable. 
 
To apply a font using the menu  

·  Select the text  

OR  

·  Click at the point you want the changes to take effect from  
·  From the Text menu, select Font  

 
Font submenu 

·  Select a font combination from the submenu  

To apply a font using the Property Inspector  

·  Click the arrow to the right of the Default font box on the Property Inspector  
·  Select a font combination from the list  
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Default font box on the Property Inspector 

Applying Font Sizes 
 
You cannot specify a font size in points on a basic HTML page in the way of printed documents. The default font size 
used for the page is set by the user in his or her browser. 
 
In Dreamweaver, you can apply relative font sizes. The default size is 3. You can apply 1-2 for text smaller than the 
default or 4-7 for text larger than the default. 
 
To change the font size  

·  Select the text or click where you want the changes to apply from  
·  From the Text menu, select Size  

 
Text Size submenu 

·  Select the required size from the submenu  

Tip: You can also change the font size using the Property Inspector. 
 
To change the font style 
 
There are a wide variety of font styles (or enhancements) available in HTML. As well as physical styles, such as 
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bold, italic and underline, you can use logical styles such as Keyboard, for text intended to be typed by the user or 
Definition, for the first time a term is used in a document. These logical styles are interpreted by the browser and 
displayed differently from normal text. For example, Keyboard appears in a monospace font, such as Courier New. 
Definition is displayed in italics.  

·  Select the text or click where you want the changes to apply from  
·  You can apply bold or italic by clicking the buttons on the Property Inspector  

 
Bold and italic buttons on the Property Inspector 

·  To select from a wider range of styles, from the Text menu, select Style  

 
Changing the Font Style 

·  Select the appropriate style from the submenu  

Aligning Text 
 
Text can be aligned on the page either from the Text menu, or using the Property Inspector. 
 
To align text on a page  

·  Select the text or click where you want the changes to apply from  
·  From the Text menu, select Align  
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Text Alignment options 

·  Select an alignment option from the submenu  

OR  

·  Select an appropriate alignment option using the buttons on the Property Inspector  

 
Alignment button on the Property Inspector 

Formatting Shortcut Keys 

 

Applying Colour to Text 
 
The Page Properties dialogue box lets you setup a colour scheme for the whole page. You can define the colours of 
body text, links and followed links. You can override these defaults by applying a different colour to text using the 
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Property Inspector. 
 
Some colours will not display correctly on certain systems. The colour palette used on the Property Inspector lets you 
choose from a selection of web-safe colours. If you want to use different colours to these, test your pages carefully. 
 
Creating an effective colour scheme can be very problematic. Look at other websites to find out what works. 
Remember that your priority must be the legibility of text. Make sure there is a high contrast between the text and 
background; either dark text on a light background or vice versa. Not only is it less tiring to read, but a significant 
proportion of the population has some form of "colour blindness", which means that they will not be able to detect 
subtle differences between different shades (for example, between shades of red and green). 
 
To define the default text colours  

·  From the Modify menu, select Page Properties...(SpeedKey: Ctrl + J)  

The Page Properties dialogue box is displayed. 

 
Page Properties dialogue box 

·  Select the colours for Text:, Links:, Visited Links: and Active Links  

Tip: Active Links is a colour set for the link when it is clicked. Not all browsers will display this effect.  

·  Click OK  

To change the colour of text  

·  Select the text or click where you want the changes to apply from  
·  Click the Text colour button on the Property Inspector  
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Text Colour button on the Property Inspector 

·  Select the required colour  

Tip: If you move the pointer over the page with the colour palette open, an eye dropper is displayed allowing you to 
select an existing colour from anywhere on the page. The closest match on the web-safe palette will be selected. You 
can also apply colours using the Text, Color... option, but this displays the system colour palette, not a web-safe one. 
 
Setting the Page Title 
 
The document title is important because it identifies the web page to the user. The title appears on the browser title 
bar, in favourite/bookmark lists and in history lists. 
 
The title is also important because it is one of the main factors influencing search results, allowing people to find the 
page on the internet. 
 
Every page in your website should have a title. 
 
Note: The default title is Untitled Document. Saving the page does not change the default title. 
 
To change the title of a page  

·  From the Modify menu, select Page Properties...(SpeedKey: Ctrl + J)  

The Page Properties dialogue box is displayed. 

 
Page Properties dialogue box 

·  Replace the existing text in the Title: text box with the title for the page  

You can use a long name for the title, but bear in mind that because it appears in users' lists, a very long name will 
probably annoy them.  
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·  Click OK  

The title is displayed in the title bar of the page window (and in the toolbar, if it is displayed). The file name of the page 
and the folder the file is saved in appear in parentheses next to the title in the title bar. 
 
Tip: You can also change the page title by typing into the box on the toolbar. 
 
Saving a Page 
 
It is important to save your work regularly to prevent loss of data. An asterisk displayed in the title bar indicates that the 
page has been edited but not saved. 
 
To save a page  

·  From the File menu, select Save (SpeedKey: Ctrl + S)  

If the document has not already been given a file name, the Save As dialogue box is displayed.  

·  From the Save in: drop-down box select the drive and folder you want to save the page into  
·  In the File name: box replace the existing text with the name for the file  

Note: You do not need to type the web page file extension (.HTM). Dreamweaver adds this automatically. Do not use 
spaces or unusual punctuation characters in a file name. Keep to alphanumerics and the underscore (_). Do not use 
very long file names (up to about 30 characters is safe).  

·  Click Save  

Inserting images  

When you insert an image into a Dreamweaver document, Dreamweaver automatically generates a reference to the 
file in the HTML source code. Like other files that are part of a website, image files must also be saved somewhere 
within the local root folder defined for the site. If your image file is not in the current site, Dreamweaver asks whether 
you want to copy the file to the root folder.  

For more information about sites, see the article Understanding Sites.  

To insert an image:  

1  Transfer the image file to a directory in your site before inserting the image, if it is not already in your current site. 

 Tip: It is a good idea to store your images in a separate directory called "images." 

2  Place the insertion point where you want the image to appear in the Document window, and do one of the following: 

 Select Insert > Image. 

 Click the Insert Image button on the Common category of the Objects panel (Window > Objects).  
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 Press Control+Alt+I (Windows) or Command+Option+I (Macintosh). 

 Drag the Insert Image button from the Objects panel to the desired location in the Document window. 

 The Select Image Source dialog box opens. 

3  Navigate to the file you want to insert and select it, or type the path for the image file in the URL text box.  

 



� � � � � � � � � � � � 	 
 � � 	 � � � � 
 � � � � � � � � � � �

  

If you are working in an unsaved document, Dreamweaver generates a "file://" reference to the image file. When you 
save the document in the site, Dreamweaver converts the reference to a document- or site root-relative path. For more 
information, see "About document locations and paths" in Chapter 15 of Using Dreamweaver 4, or in Dreamweaver 
Help (Help > Using Dreamweaver). 

Image alignment  

Use the Property inspector (Window > Properties) to set the alignment of a selected image. You can align an image in 
relation to text, another image, a plug-in, or other elements in the same paragraph or line by selecting alignment 
settings from the Align pop-up menu. You can also use the alignment buttons (left, right, and center) to set the 
horizontal alignment of an image.  

 

Browser Default generally specifies a baseline alignment. (The default may differ depending on the site visitor's 
browser.)  

Baseline and Bottom align the baseline of the text (or other element) to the bottom of the selected image.  



� � � � � � � � � � � � 	 
 � � 	 � � � � 
 � � � � � � � � � � �

 

Top aligns an image to the top of the tallest item (image or text) in the current line.  

Middle aligns the text baseline with the middle of the selected image.  
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TextTop aligns the selected image with the top of the tallest character in the text line (which includes ascenders, as in 
the letter b).  

Absolute Middle aligns to the absolute middle of the current line.  

Absolute Bottom aligns to the absolute bottom (which includes descenders, as in the letter g) with the bottom of the 
selected image.  

Left places the selected image on the left margin, wrapping text around it to the right.  
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Right places the selected image on the right margin, wrapping text around it to the left. 

Adding space around images  

If you want to add space around an image (for example, if you want a space between an image and the text that 
appears next to the image), use the V Space and H Space text boxes in the Property inspector.  

To add space around an image:  

1  Select the image in the Document window. 

2  Select Window > Properties to open the Property inspector, if it is not already open. 

3  Click the expander arrow to expand the Property inspector to its full dimensions, if necessary.  
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4  In the Property inspector, do any of the following: 

 Type a value in the V Space text box to add space in pixels along both the top and bottom of an image. 

 Type a value in the H Space text box to add space in pixels along both the left and right of an image. 

Associating a remote server with a local site  

After you've created a local site, use the Define Sites command to add or change associated remote 
server information.  

To associate a remote server with an existing local site:  

1  In Dreamweaver 4, choose Site > Define Sites. 

 A dialog box appears listing currently defined sites.  
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2  Select an existing site and click Edit. 

 If you have no currently defined sites, create a local site before proceeding. 

3  In the Category list at the left, choose Remote Info.  

 
4  Choose one of the following Access options: 

 Use FTP if you connect to your Web server using FTP. Then skip to the next procedure.  
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Note: FTP is the most commonly used server access option. If you aren't sure what to choose 
here, FTP is likely to be the right choice (but check with your ISP or system administrator to be 
sure). 

 Choose Local/Network if your Web server is on the local network, or if you are running a Web 
server on your local machine. Click the folder icon to browse to and select the folder where your 
site files are stored on the server. Click OK and then click Done in the Define Sites dialog box.  

 

  

To connect to a Web server using FTP:  

1  In the FTP Host field, enter the host name of the server to which you intend to upload files for your 
Web site.  

 

 The specific information required to make an FTP connection is unique to each server. If you aren't 
sure about some of this information, ask your ISP or your system administrator. 

 
Your FTP host name is the full Internet name of a computer system, such as ftp.mindspring.com. 
Enter the full host name without any additional text (such as the protocol name http://) in front of 
the host name. For example: 

 Right: ftp.mindspring.com 

 Wrong: ftp://ftp.mindspring.com 

 Wrong: mindspring.com 

  

Note: Not all FTP host names start with FTP.  

2  In the Host Directory field, enter the name of the folder on the remote site where you want to store 
the documents to make them visible to the public. (This folder or directory on the server 
corresponds to the local root folder on your local disk.) See Determining the remote site's host 
directory (FTP only).  

 

 
Note: In some cases, a server may be configured to automatically route you to the correct 
directory by default. In that case you may leave the Host Directory field blank. If your server isn't 
set up like that, though, you have to enter a host directory. 

3  In the Login and Password fields, enter the login name and password that you use to connect to 
the FTP server. 

4  Select appropriate firewall options for your site (if you don't have a firewall, don't select either of 
these options.): 

 If your firewall configuration requires use of passive FTP (which lets your local software set up the 
FTP connection rather than requesting the remote server to set it up), select Use Passive FTP. If 
you're not sure, check with your system administrator. 
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 Select the Use Firewall option if you are connecting to the remote server from behind a firewall. 

5  Click OK. 

 

The Define Sites dialog box reappears.  

 
6  Click Done. 
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